Friday 19 May 2017

Software management in AIX

Fileset in AIX is named for softwares or dependencies.
Group of filesets is called a package.
For eg: bos.net is a package and bos.net.nfs.client is a fileset.
BOS stands for Base Operating System.
BOS is a licensed programming product (LPP).
Bundle : A bundle is a collection of a fileset, package or LPP.
Bundle is of 3 types:
  1. Server bundle
  2. Graphics bundle
  3. Migration bundle
Command used to install softwares is installp
Various commands to install software:
# installp –aVx –d <directory or device name> <application name>
For eg:
# installp – aVx –d /dev/rmt0 bos.net.nfs.client
Flags:
a stands for APPLIED mode. Software installed in applied mode means, admin can rollback the software if the wrong version gets installed or software is not suited as per end user requirements. Because the software is not committed to the OS, so rollback is possible.
To commit the software/application permanently in the OS, command used:
# installp –aCx –d <directory or device name> <application file>
For eg:
# installp –aCx –d /dev/rmt0 bos.net.nfs.client
Flags:
c stands for COMMITTED mode. Once the application is installed using c flag, it cannot be removed later from the OS. Admin must be very careful in running this command.
To remove an application which is installed in applied mode, command used is:
# installp –r <application name>
To uninstall the fileset, command used:
# installp –u <application name>
To clean broken software parts, command used:
# installp –C
To check all softwares installed in APPLIED mode, command used:
# installp –S
To list all the softwares installed in AIX or LINUX OS, command used are:
# lslpp –l (works only in AIX)
# lslpp –L (works in both AIX as well as Linux)
# lslpp –h <application name>
This command will give complete history about the application including the versions installed.
For eg:
# lslpp –h bos.obj
# lslpp –L | grep APPLIED
Will list all the applications installed in APPLIED mode in the OS.
Command used to find the filesets installed for a particular application is:
# lslpp –f <application name>
Command used to find the filesets installed for running any command is:
# lslpp –w /usr/bin/<command>
For eg:
# lslpp –w /usr/bin/path
This command will give the list of filesets needed to run the PATH command.
# lslpp –c command is used to verify the checksum
# lslpp –v command is used to verify the software parts.
To install softwares in Linux commands used are:
# rpm –ivh <application name>
POINTS TO REMEMBER:
Install command’s output is always stored in user’s smit.log directory i.e. /home/smit.log
Software components are basically broken down into 3 types:
  1. Root
  2. Usr
  3. Share
Fileset + package together is called a Bundle.
To check using SMIT whether software is installed properly or not, command used is:
# smit list_installed
To report comparison for softwares, command used:
# smit compare_report
To check software management and utilities, command used:
# smit maintain_software
To install fix from a cd, command used:
# instfix –ik <fix number> -d /dev/cd0
To search for a fix by keyword:
# instfix –s <keyword> -d /dev/cd0
To display all fixes available on cd:
# instfix –T –d /dev/cd0
# instfix –I | grep ML command will list all the fixes for ML (maintenance Level)
# instfix –I | grep TL command will list all the fixes for TL (Technology Level)
Formula for RISC (Reduced Instructions Set Computer):
Time to execute a program = number of instructions X number of clock cycles per instruction X time taken for a clock cycle
mkinstallp command creates software package in install format.
To install updates available on a cd and verify the current maintenance level, command used is:
# install_all_updates –d /dev/cd0

No comments:

Post a Comment