Software States:
When a software or an update is first installed, it is in the APPLIED state. It can be later commited or rejectd.
APPLIED state
- Provide opportunity to test the software
- Enable to go back to the previous version in case of any problem
- Enable to commit software at a later stage
- Requires more disk
- Prevents future re-installation of product
COMMITED state
- Requires less disk space
- Permits future upgrade
- Prevents from easily going back to previous version
Reject action removes the APPLIED software and go back to the previous commited version
List the installed filesets/fileset updates
To list all the installed software
# lslpp -l
To display the maintenance level and state of a fileset
# lslpp -l bos.net.nfs.client
Lists installed software using ':' as the delimeter
# lslpp -Lc
To display the names of all the files of fileset bos.perf
# lslpp -f bos.perf
To find out which fileset a file belongs to
# lslpp -w /usr/sbin/nfsd
To list installation history of filesets
# lslpp -ha
To the filesets that do not have the required prerequisites or are not completely installed
# lslpp -v
Install filesets / software
installp command is used to install the software. The options are
-a Install filesets in APPLIIED state -c Commit filesets -r Reject filesets which are in APPLIED state -u Uninstall filesets -C Cleanup failed installtion -g To Install or Uninstall dependencies -x To expand file systems if there is not enough space -d <device> Device or directory which contains the software -f <filename> User created file which has a list of software to be installed or deleted
Emaples:
To list all installable software in media /dev/cd0
installp [-L|-l] -d /dev/cd0
To cleanup all failed installtion
installp -C
To install bos.net software (apply and commit) package with all pre-requisites from directory /tmp/net
installp -acgx -d /tmp/net bos.net
To commit teh applied updates
installp -cgx all
To remove bos.net package
installp -ug bos.net
instfix coomand is used to install a fix or set of fixes. It is also used to find out if a fix is installed on a system.
To find out whether a Fix is installed or not
# instfix -i -k <APAR Number>
To list all the fixes that are installed on your system
# instfix -i -v
To list filesets which are lesser than the specified maintenance level
# instfix -ciqk 5100-04_AIX_ML | grep ":-:"
To install all filesets associated with fix Ix38794 from the tape
# instfix -k Ix38794 -d /dev/rmt0
To Display the entire list of fixes present on the media
# instfix -T -d /dev/cd0
To confirm the AIX preventive maintenance level on your system
# instfix -i | grep ML All filesets for 5.0.0.0_AIX_ML were found. All filesets for 5.1.0.0_AIX_ML were found. All filesets for 5.1.0.0_AIX_ML were found. All filesets for 5100-01_AIX_ML were found. All filesets for 5100-02_AIX_ML were found.
To verify that all filesets have all required requisites and are completely installed
#lppchk -v
oslevel command is used to find out the version and maintenance level of AIX
To see the current OS and Maintenance level
# oslevel
# oslevel
# oslevel -r - To see the current maintenance level # oslevel -s - To see the current service pack level # oslevel -l 4.1.2.0 - To determine the file sets that are below level 4.1.2. # oslevel -g - To determine the file sets that are later than the current maintenance level # oslevel -rq - To list all known recommended maintenance levels on the system
Updating the software to the latest level
01. Using smit
# smit update_all
02. To update all filesets in a system using command line
a. Create the list of filesets installed # lslpp -Lc | awk -F: '{print $2}'| tail -n +2 > /tmp/lslpp b. Update the softwares using installp command # installp -agxYd /dev/cd0 -e /tmp/<exclude_list> -f /tmp/lslpp
Another way of updating all the filesets
# /usr/lib/instl/sm_inst installp_cmd -acgNXY -d <localtion_of_updates> -f '_update_all'
For not committing and saving all replaced files
# /usr/lib/instl/sm_inst installp_cmd -agX -d <localtion_of_updates> -f '_update_all'
To list all the installed efixes on a system
# emgr -l
To install a efix IY93496.070302.epkg.Z in /mnt directory
# emgr -e /mnt/IY93496.070302.epkg.Z
inutoc
The inutoc command creates the .toc file in Directory. If a .toc file
already exists, it is recreated with new information. The inutoc command
adds table of contents entries in the .toc file for every installation
image in Directory.
The installp command and the bffcreate command call this command automatically upon the creation or use of an installation image in a directory without a .toc file
To create a .tocfile for the /tmp/images directory, enter:
# inutoc /tmp/images
bffcreate
The bffcreate command creates an installation image file in backup file
format (bff) to support software installation operations. It creates an
installation image file from an installation image file on the specified
installation media
To create an installation image file from the bos.net software package
on the tape in the /dev/rmt0 tape drive and use /var/tmp as the working
directory, type:
# bffcreate -d /dev/rmt0.1 -w /var/tmp bos.net
No comments:
Post a Comment