Friday 19 May 2017

Paging [AIX]

Swap space related commands and files in AIX
 swapon
 swapoff
 lsps
 chps
 mkps
 rmps
 /etc/swapspaces
swapon: Used to activate a paging space.
   swapon -a --> activates all paging devices specified on /etc/swapspaces
   swapon < Device Name > --> Activates the specified paging space
mkps: This command is used to add an additional paging space.
Syntax:
       mkps [ -a ] [ -n ] [ -s Number of LPs ] VG_Name
          -a activates the paging space during next reboot
          -n activates the paging space immediately
chps: This command is used to change the attributes of a paging space
Syntax:
       chps [ -a LPs | -d LPs ] [ -a { y | n } ] paging_space_name
          -s Specifies the number of logical partitions to add 
          -d specifies the number of logical partitions to subtract
          -a To specify to use the Paging Space at the next reboot

Cookbook to add / remove paging space dynamically

To add a paging space "paging0"

01. Create a new LV for paging space
      mklv -t paging -y paging0 rootvg 10
02. Add the entry in /etc/swapspaces to activate the paging space during next reboot
      chps -a y paging0
03. Activate the paging space
      swapon /dev/paging0

To remove an active paging space "paging00"

1. Deactivate the paging space using swapoff commnad
   # swapoff /dev/paging00
2. remove the paging space using rmps command
   # rmps paging00
03. Remove the entry from /etc/swapspaces so that it is not activated during next reboot
   # chps -a n paging00

No comments:

Post a Comment