PowerVM QuickStart V-VIOS Device Management
1.Disk
2.Devices
3.Low Level Redundancy Configuration
4.Best Practices / Additional Notes
1.Disk:
Determine if SCSI reserve is enabled for hdisk4
lsdev -dev hdisk4 -attr reserve_policy
Turn off SCSI reserve for hdisk4
chdev -dev hdisk4 -attr reserve_policy=no_reserve
Re-enable SCSI reserve for hdisk4
chdev -dev hdisk4 -attr reserve_policy=single_path
Enable extended disk statistics
chdev -dev sys0 -attr iostat=true
List the parent device of hdisk0
lsdev -dev hdisk0 -parent
List all the child devices of (DS4000 array) dar0
lsdev -dev dar0 -child
List the reserve policy for all disks on a DS4000 array
for D in `lsdev -dev dar0 -child -field name | grep -v name`
do
lsdev -dev $D -attr reserve_policy
done
2.Devices:
Discover new devices
cfgdev
››› This is the VIOS equivalent of the AIX cfgmgr command.
List all adapters (physical and virtual) on the system
lsdev -type adapter
List only virtual adapters
lsdev -virtual -type adapter
List all virtual disks (created with mkvdev command)
lsdev -virtual -type disk
Find the WWN of the fcs0 HBA
lsdev -dev fcs0 -vpd | grep Network
List the firmware levels of all devices on the system
lsfware -all
››› The invscout command is also available in VIOS.
Get a long listing of every device on the system
lsdev -vpd
List all devices (physical and virtual) by their slot address
lsdev -slots
List all the attributes of the sys0 device
lsdev -dev sys0 -attr
List the port speed of the (physical) ethernet adapter eth0
lsdev -dev ent0 -attr media_speed
List all the possible settings for media_speed on ent0
lsdev -dev ent0 -range media_speed
Set the media_speed option to auto negotiate on ent0
chdev -dev ent0 -attr media_speed=Auto_Negotiation
Set the media_speed to auto negotiate on ent0 on next boot
chdev -dev ent0 \
-attr media_speed=Auto_Negotiation \
-perm
Turn on disk performance counters
chdev -dev sys0 -attr iostat=true
3. Low Level Redundancy Configuration:
•
Management and setup of devices requiring drivers and tools not
provided by VIOS (ie PowerPath devices) will require use of the root
shell available from the oem_setup_env command.
•
Tools installed from the root shell (using oem_setup_env) may not be
installed in the PATH used by the restricted shell. The commands may
need to be linked or copied to the correct path for the restricted
padmin shell. Not all commands may work in this manner.
• The mkvdev -lnagg and cfglnagg commands can be used to set up and manage link aggregation (to external ethernet switches).
• The chpath, mkpath, and lspath commands can be used to manage MPIO capable devices.
4.Best Practices / Additional Notes
•
Virtual Ethernet devices should only have 802.1Q enabled if you intend
to run additional VLANs on that interface. (In most instances this is
not the case).
• Only one interface should be configured to "Access
External Networks" on a VLAN, this should be the virtual interface used
for the SEA on the VIOS and not the VIOC. This is the "gateway" adapter
that will receive packets with MAC addresses that are unknown. (This is
also known as a "Trunk adapter" on some versions of the HMC.)
• VIOS
partitions are unique in that they can have virtual host adapters.
Virtual SCSI adapters in VIOC partitions connect to LUNs shared through
VIOS virtual host adapters.
• An organized naming convention to
virtual devices is an important method to simplifying complexity in a
VIOS environment. Several methods are used in this document, but each
represents a self-documenting method that relates what the virtual
device is and what it serves.
• VIOS commands can be run from the
HMC. This may be a convenient alternative to logging into the VIOS LPAR
and running the command.
• Power 6 based systems have an additional
LPAR parameter called the partition "weight". The additional RAS
features will use this value in a resource constrained system to kill a
lower priority LPAR in the event of a CPU failure.
• The ratio of
virtual CPUs in a partition to the actual amount of desired / entitled
capacity is a "statement" on the partitions ability to be virtualized. A
minimal backing of actual (physical) CPU entitlement to a virtual CPU
suggests that the LPAR will most likely not be using large amounts of
CPU and will relinquish unused cycles back to the shared pool the
majority of the time. This is a measure of how over-committed the
partition is.
• multiple profiles created on the HMC can represent
different configurations such as with and without the physical CD/DVD
ROM. These profiles can be named (for example) as _prod and _cdrom.
• HMC partition configuration and profiles can be saved to a file and backed up to either other HMCs or remote file systems.
•
sysplan files can be created on the HMC or the SPT (System Planning
Tool) and exported to each other. These files are a good method of
expressing explicit configuration intent and can serve as both
documentation as well as a (partial) backup method of configuration
data.
• vhost adapters should be explicitly assigned and restricted
to client partitions. This helps with documentation (viewing the config
in the HMC) as well as preventing trespass of disks by other client
partitions (typically due to user error).
No comments:
Post a Comment